Can I use Chrome for my browser in the Entity Admin Portal?

No. The Entity Admin Portal requires the use of Internet Explorer 8 or newer as the browser. You can still access other ADE systems using Chrome, just not the Entity Admin portal.

Return to ADEConnect Home Page.