Internet Explorer 10

Please be advised that the current GME system does not support Version 10 of Internet Explorer (IE).  We have found that users that have upgraded to this version of the browser are not able to save amendment and application data.  The system continues to support Version 8 IE.  The new GME system will however support newer versions, like 10, of IE within the coming fiscal year. 

If you are having issues with your amendments, applications or completion reports saving, review the version of IE you are using.  If you are still having issues please feel free to contact Sarah Hendrix, 602 542-4494 or Sarah Heikkila 602 542-4339 for assistance.

Just as a reminder, the current GME system still only supports IE.